UE4 error deploying to iOS

Howdy, MGSA!

I was hoping someone here could maybe help me with an issue I'm having. I know UE4 isn't particularly popular around these parts, but I thought I'd give it a shot anyway. I'm trying to deploy my game to iOS (just for testing), but when I do, I get this error:

LogPlayLevel: ERROR: System.FormatException: Input string was not in a correct format.

My mobile provision is green and valid and my certificate is valid too. I'm currently on 4.18.3 and It's a Blueprint-only project. Of course, I've profusely googled the issue, but alas, no answers (or, so many answers, non of which helped solve the issue).

If anybody has any experience with this issue, I would really appreciate some help. I'm super desperate as I can't continue development without knowing if my game would run on iPhone.

Thanks in advance! ♥


  • Can you post the rest of your log file?
  • @DarkRa88iT
    Going out on a limb here, but from my iOS work I know that Single.Parse uses the current culture of the build device to parse the strings.
    In your project, do you specify the build version / app version anywhere?
    If so, try changing full stops ('.') to comma's (',') in your version numbers.

    For example, using the culture variant call (which I assume UE4 is using)
    which calls
    System.Number.ParseSingle(String value, NumberStyles options, NumberFormat Info numfmt)
    will fail, whereas
    will succeed

    On iOS we generally use
    float.Parse("6.59", CultureInfo.InvariantCulture)
    but I don't know if you can use that call in UE4. So maybe just try using commas in the version numbers and let me know.
  • Thanks! I'll give it a shot and report back :)
  • Ok, so I went though all the places where I could find a version number, changed them to have commas and it didn't work. On my travels though, I found a "Marketing Image" that was missing and highlighted in red. So I put an image in there at the right dimensions and tried again. Now I'm not getting that same error anymore, but rather this one:

    https://pastebin.com/embed_js/S9Q7acG2 (Only the last 20 or so lines, as the full log was too big for Pastebin non-Pro)

    I'm sorry if this is super nooby, but I'm an utter super noob. So as always, any help is very much appreciated!
  • No worries.
    So I'm not that experienced with UE4, but I know iOS pretty well.
    So from this:
    LogPlayLevel:   ERROR: Remote compiling requires a server name. Use the editor (Project Settings, IOS) to set up your remote compilation settings.
    LogPlayLevel:   Doing xcode-select --print-path
    LogPlayLevel:   ERROR: Failed to start local process for action ("Cannot start process because a file name has not been provided."):  -o BatchMode=yes  ${CURRENT_USER}@ "cd \\"/\\" && xcode-select --print-path"

    I see you are building on a Windows machine. To build anything for iOS, the code signing requires that the build actually happens on a Mac.
    It looks like all that is wrong now is that you don't have a specified server (which would be the mac on which it will build the iOS bits)

    Do you have a Mac on which you can build? Or at least know of a Mac server that you can specify for the build? I'm a little fuzzy on this part from the UE4 side of things.
  • Hi @TheCorinthian (epic name, btw). Thanks again for the reply! Yeah, I am so incredibly far from a Mac, i can't imagine a way of getting my hands on one (none of my friends or family have Macs either). So this truly makes me very sad. The game I'm building is a VERY simple, one-tap-input, aimed-at-mobile game that no one in their right mind would play on a desktop. And to top it off, the only mobile devices I have access to for testing are iPhones >.< I'm sad now.

    But in my reading on the subject, I came across multiple people (including Epic staffers) mentioning that you can build to iOS from PC (without a remote Mac) under these very specific circumstances:

    - The project is Blueprint ONLY (which mine is)
    - You don't use any plugins (which I don't, sort of*)

    * So I don't have any plugins installed that didn't come with UE4. But yesterday, I tried a build of an empty, example project, as supplied by Epic. That also failed. So I went through the list of plugins that are installed and disabled literally all of them. Tried to build again and I at least got a different error (yay?) , but the build still failed. So next thing I'm going to try is to remove plugins one-by-one to see if there's a sweet spot where it'll still build, but not need a Mac to do it.

    Failing that, can anyone suggest a remote-Mac service I should use? Of course, I'd prefer some sort of free service, but I know that's a long shot. I've already dumped the R1300 into the stupid Apple developer program, I'd hate to possibly waste more money.
  • So yeah,
    Getting a mac server as a service tends to be very expensive.
    These guys ( https://www.macstadium.com/ ) offer a free trial, but I've never heard of them before.
    While I've used these guys before ( https://portal.macincloud.com/select/#/plans ) and they have a $1 / hour pay as you go option.

    What I could do is build it for you (I have access to a Mac) but I would understand if you're skittish to throw your projects around.
    Let me know and we can set something up
  • Good Morning!

    So after trying many, many other things (including downloading lower versions of the engine), I've had no success. I do believe it is an Unreal Engine issue, as I've seen people say they were still able to deploy their games until quite recently (like, 2 or 3 months ago). So I'm just totally pooped there.

    Thank you for the offer, @TheCorinthian. I would actually really like to take you up on that. This is my first game (at least, the first that I've gotten this far), so I don't expect it revolutionize the gaming industry :P Hence, not that precious about it. If I could just have one build to see if it works on iPhone AT ALL, I can then justify getting one of these services or try to find a second-hand Mac Mini or something like that for further development.

    How would I go about 'packaging' the project to hand over to you? Just a zip of the folder? I'm also assuming I'd have to include my mobile provision and certificate thingy.

    Thanks again for the help ♥
  • @DarkRa88iT
    I've sent you a PM with my email address.
    Drop me a mail and we can make arrangements
Sign In or Register to comment.