[CGA Jam entry] Astropunk


I made a game for recent CGA Jam. https://sleepingsafari.itch.io/astropunk-history-repeats-itself

I am still very much a novice so excuse any strange bugs I might have missed (this is only the second game I've ever finished). Someone mentioned that their screen just goes black when launching. Have no idea what could cause that?

Feedback is encouraged, so please don't hesitate! Rip me apart if you have to, it's all about learning ;)

Theme used was "Gravity". More info can be found on itch page.

Astropunk_History Repeats Itsel 2017-06-14 16-24-08-56.jpg
1600 x 900 - 95K


  • I can't see any graphics when I run it. I can here some sounds (music and some shooting sounds) if I mash the keyboard. But it's all on a black screen.

    From the image, the little dude seems cool. The asteroids look a bit like eggs, though I'm not sure if that is by design and dinosaurs hatch out of them.
  • Thanks for taking the time to play @EvenGreenwood! Haha, no they're supposed to look like asteriods but I can definitely see the similarities to dinosaur eggs. My art skills are still a bit lacking (although the colour palette could also play a small role in this misconception?).

    I'm still not sure what's causing this as I have trouble recreating it on other systems. Tested it on four different PC's and it worked on all of them (all Windows 7 though).

    Did some Googling and spotted a forum kind of talking about the same black screen error. In this case, before creating the playable build, you had to set the "Vertex Buffer Method" to "Most Compatible" (mine was "Compatible") in Game Maker.

    I made a new build with this change so if you have a chance to check it out, please do, and let me know if the problem persists.

    Astropunk_History Repeats Itself.zip
  • It still doesn't display anything :(

    I'm pretty certain other gamemaker games have worked on my system. No idea why this one doesn't.
  • Ah that sucks : (

    Totally stumped. Tried this on Windows 10 system as well and it worked, so atm I have no idea why only a small number of people are experiencing this. Hopefully the Oracle of Google will bless me with an answer.

    Thanks for giving it another go though, @EvanGreenwood!

    Thanked by 1EvanGreenwood
  • Sorry I couldn't be of more help. Probably some quirk of my setup (I guess I blame Asus and NVidia conspiring against themselves and Windows 10).
  • Yo @EvenGreenwood,

    It seems the problem is linked specifically to a bug between Game Maker and recent Windows 10 updates. I referred the issue to GM forums and it ended up sparking a whole debate:


    Anyway, I think the problem is fixed now. Had to turn on Vsync before creating the build. If you could please check out the attached build and see if the issue is fixed for you, that would be seriously appreciated!
    Astropunk_History Repeats Itself.zip
Sign In or Register to comment.