Gamemaker studio Android export help

I have bought the Android export for Gamemaker Studio and downloaded what I thought was the android sdk, but when I try and link the path GM keeps telling me that it cant find the sdk. I am at my wits end. Somebody save me! (wailey wailey wailey)


  • Setting up Android is a rather large pain in the ass.

    You need:

    Android SDK
    Android NDK
    Java JDK


    Once you have all of those you need to update the Android SDK so that it has all the required modules installed. Can't really remember what you need, but if you Google the outputs for GM and follow the errors to the posts on GMC it should have a guide there of what you need (it's what I followed when setting it up)

    Also just remember that there are horizontal (on the top) and vertical (on the left) tabs in the options menu. The UI kills me. Since the important stuff is in the vertical tabs and I always forget they are there.

    Sorry that I can't be of more help, did this a while ago and can't really remember the specific details of setting it up.
    Thanked by 1duncanbellsa
  • I followed this guide and it seemed to work just fine:

    These are things I didn't notice when I spped-read the instructions :)
    To get the SDK Installer, rather than the ADT Bundle, you should scroll down the developers page and click the link marked "Download For Other Platforms", then select the "recommended" installer from the section labelled SDK Tools Only and follow these steps:
    Run the Android SDK installer. If you do not have the Java SE Development Kit (JDK) you will also be prompted to download and install this before continuing. You will be asked to install the Android SDK to the path "C:\Program Files (x86)\Android\android-sdk". We strongly recommend that you choose an alternative path (for example : "C:\Android\android-sdk") as the default path can cause problems with GameMaker:Studio as well as the actual Android updater program itself.
    When it starts you should select Android SDK Platform Tools, Android 2.1 (API 7), Android 2.2 (API 8), Android 3.2 (API 13), Android 4.0.3 (API 15), as well as the most recent version of Android (selected automatically by default by the manager).
    Thanked by 1Karuji
  • Thanks all for the replies, I have followed these steps originally and I am still not working. I shall re-attempt this.
  • @duncanbellsa danka. Need to save that for the next time I install GM #HopeINeverHaveToFormat

    @Pillar: Any chance you can give us a breakdown of the steps you have done or tell us what errors GM is giving you?
  • I have followed the steps exactly as I have found them here:

    I went to the page and downloaded Windows
    32 & 64-bit. I downloaded everything to C:/android/android then I try to set up the path in GM to find the SDK.

    The issue is that GM says that the SDK is not found, and I have tried every single path configuration that I can think of. When I go into the android download manager, I do not see the SDK as downloadable item as I have on screen shots of what I am looking for. I have tried clearing the cache and refreshing the list. Unless I am being a total wally, I am following the steps.
  • Ah right: had a similar problem when I was doing my set-up. For the the 'cannot find SDK' error was because I hadn't downloaded the right update things for SDK.

    Here are some caps from my SDK manager of what I have installed

    521 x 399 - 40K
    492 x 580 - 52K
  • AH HA! Thank you, API 13 was not loading, I had to clear my cache. It works. Its alive...ALIIIVVVEE
  • Glad that it's working :)
  • AH HA! Thank you, API 13 was not loading, I had to clear my cache. It works. Its alive...ALIIIVVVEE
    what cache did you clear? I have the same problem.

Sign In or Register to comment.